ByXiaoXie

Gary

头像

@byxiaoxie2年前

05/24
10:08
Home

路由器与交换机配置学习记录(18-5-24已更新)

三层交换机配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

三层交换机的配置:
Switch>enable
Switch#config
Switch(config)#vlan 10 //创建Vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#exit
Switch(config)#int f0/1 //给fa0/1端口设置vlan 10
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#int f0/3
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit
Switch(config)#int vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int vlan 20
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int vlan 30
Switch(config-if)#ip address 192.168.30.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int f0/24
Switch(config-if)#no switchport //启动端口
Switch(config-if)#ip address 10.0.0.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.2  //设置10.0.0.2为静态路由
Switch(config)#ip routing  //启动路由功能
Switch(config)#exit

路由器的配置:
Router>enable
Router#config
Router(config)#int f0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.40.1 255.255.255.0
Router(config-if)#exit
Router(config)#int f0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 10.0.0.2 255.255.255.0
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1 //设置10.0.0.1为静态路由
Router(config)#exit


三层交换机互联拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

三层交换机A的配置:
Switch>enable
Switch#config
Switch(config)#vlan 10 //创建Vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#int f0/1 //给fa0/1端口设置vlan 10
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#int vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int vlan 20
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int f0/24
Switch(config-if)#no switchport //启动端口
Switch(config-if)#ip address 192.168.100.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.100.2  //设置192.168.100.2为静态路由下一跳
Switch(config)#ip routing  //启动路由功能
Switch(config)#exit


三层交换机B的配置:
Switch>enable
Switch#config
Switch(config)#vlan 30 //创建Vlan 30
Switch(config-vlan)#exit
Switch(config)#vlan 40
Switch(config-vlan)#exit
Switch(config)#int f0/1 //给fa0/1端口设置vlan 10
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 40
Switch(config-if)#exit
Switch(config)#int vlan 30
Switch(config-if)#ip address 192.168.30.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int vlan 40
Switch(config-if)#ip address 192.168.40.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int f0/24
Switch(config-if)#no switchport //启动端口
Switch(config-if)#ip address 192.168.100.2 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.100.1  //设置192.168.100.1为静态路由下一跳
Switch(config)#ip routing  //启动路由功能
Switch(config)#exit

三台交换机中继拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)
地址表:

设备(主机名) 接口 IP 地址 子网掩码 默认网关
S1 VLAN 56 192.168.56.11 255.255.255.0 不适用
S2 VLAN 56 192.168.56.12 255.255.255.0 不适用
S3 VLAN 56 192.168.56.13 255.255.255.0 不适用
PC1 网卡 192.168.10.21 255.255.255.0 192.168.10.1
PC2 网卡 192.168.20.22 255.255.255.0 192.168.20.1
PC3 网卡 192.168.30.23 255.255.255.0 192.168.30.1
PC4 网卡 192.168.10.24 255.255.255.0 192.168.10.1
PC5 网卡 192.168.20.25 255.255.255.0 192.168.20.1
PC6 网卡 192.168.30.26 255.255.255.0 192.168.30.1

 

初始端口分配(交换机 2 和 3):

端口 分配 网络
Fa0/1 – 0/5 802.1q 中继(本征 VLAN 56) 192.168.56.0 /24
Fa0/6 – 0/10 VLAN 30 – Guest (Default) 192.168.30.0 /24
Fa0/11 – 0/17 VLAN 10 – Faculty/Staff 192.168.10.0 /24
Fa0/18 – 0/24 VLAN 20 – Students 192.168.20.0 /24

 

Switch0-S1交换机配置:
Switch>enable
Switch#config
Switch(config)#hostname S1
S1(config)#vlan 56
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#exit
S1(config)#int vlan 56
S1(config-if)#ip address 192.168.56.11 255.255.255.0
S1(config)#interface range fa0/1-5
S1(config-if-range)#switchport mode trunk 
S1(config-if-range)#switchport trunk native vlan 56
S1(config-if-range)#no shutdown 
S1(config-if-range)#exit
Switch1-S2交换机配置:
Switch>enable
Switch#config t
Switch(config)#hostname S2
S2(config)#vlan 10
S2(config-vlan)#exit
S2(config)#vlan 20
S2(config-vlan)#exit
S2(config)#vlan 30
S2(config-vlan)#exit
S2(config)#vlan 56
S2(config-vlan)#exit
S2(config)#int vlan 10
S2(config-if)#ip address 192.168.10.1 255.255.255.0
S2(config-if)#exit
S2(config)#int vlan 20
S2(config-if)#ip address 192.168.20.1 255.255.255.0
S2(config-if)#exit
S2(config)#int vlan 30
S2(config-if)#ip address 192.168.30.1 255.255.255.0
S2(config-if)#exit
S2(config)#int vlan 56
S2(config-if)#ip address 192.168.56.12 255.255.255.0
S2(config-if)#exit
S2(config)#interface range fa0/11-17
S2(config-if-range)#switchport access vlan 10
S2(config-if-range)#exit
S2(config)#interface range fa0/18-24
S2(config-if-range)#switchport access vlan 20
S2(config-if-range)#exit
S2(config)#interface range fa0/6-10
S2(config-if-range)#switchport access vlan 20
S2(config-if-range)#exit
S2(config)#interface range fa0/1-5
S2(config-if-range)#switchport mode trunk 
S2(config-if-range)#switchport trunk native vlan 56
S2(config-if-range)#no shutdown 
S2(config-if-range)#exit
Switch2-S3交换机配置:
Switch>enable
Switch#config t
Switch(config)#hostname S3
S3(config)#vlan 10
S3(config-vlan)#exit
S3(config)#vlan 20
S3(config-vlan)#exit
S3(config)#vlan 30
S3(config-vlan)#exit
S3(config)#vlan 56
S3(config-vlan)#exit
S3(config)#int vlan 10
S3(config-if)#ip address 192.168.10.1 255.255.255.0
S3(config-if)#exit
S3(config)#int vlan 20
S3(config-if)#ip address 192.168.20.1 255.255.255.0
S3(config-if)#exit
S3(config)#int vlan 30
S3(config-if)#ip address 192.168.30.1 255.255.255.0
S3(config-if)#exit
S3(config)#int vlan 56
S3(config-if)#ip address 192.168.56.13 255.255.255.0
S3(config-if)#exit
S3(config)#interface range fa0/11-17
S3(config-if-range)#switchport access vlan 10
S3(config-if-range)#exit
S3(config)#interface range fa0/18-24
S3(config-if-range)#switchport access vlan 20
S3(config-if-range)#exit
S3(config)#interface range fa0/6-10
S3(config-if-range)#switchport access vlan 20
S3(config-if-range)#exit
S3(config)#interface range fa0/1-5
S3(config-if-range)#switchport mode trunk 
S3(config-if-range)#switchport trunk native vlan 56
S3(config-if-range)#no shutdown 
S3(config-if-range)#exit

单臂路由及VLAN的配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

配置2960交换机:
Switch>enable
Switch#config t
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#exit
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
Switch(config)#int f0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#int vlan 2
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#int vlan 3
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#exit
Switch#write

配置路由器2811:
Router>enable
Router#config t
Router(config)#int f0/0
Router(config-if)#no shutdown //开启端口
Router(config-if)#exit
Router(config)#int f0/0.1 //f0/0.1子端口
Router(config-subif)#encapsulation dot1q 2  //封装vlan2
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#exit
Router(config)#int f0/0.2 //f0/0.2子端口
Router(config-subif)#
Router(config-subif)#encapsulation dot1q 3 //封装vlan3
Router(config-subif)#ip address 192.168.3.1 255.255.255.0
Router(config-subif)#exit
Router(config)#exit
Router#write
Router#show ip route

三层交换机与单臂路由器互通拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

交换机A配置:
Switch>enable
Switch#config
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface f0/24 //连接三层交换机
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 10
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 20

交换机B配置:
Switch>enable
Switch#config
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface f0/23 //连接三层交换机
Switch(config-if)#switchport mode trunk
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 10
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 20

三层交换机配置:
Switch>enable
Switch#config
Switch(config)#ip routing  //启动路由协议
Switch(config)#int f0/24
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#int f0/23
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#int Vlan10
Switch(config-if)#ip address 192.168.1.168 255.255.255.0
Switch(config-if)#exit
Switch(config)#int Vlan20
Switch(config-if)#ip address 192.168.2.168 255.255.255.0
配置三层交换机IP
Switch(config)#int f0/1
Switch(config-if)#no switchsport
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.2 //静态路由

------------------------------------------------------------

单臂路由器:
Router(config)#int f0/0
Router(config-if)#ip address 192.168.10.2 255.255.255.0
Router(config-if)#ip route 0.0.0.0 0.0.0.0 192.168.10.1
Router(config)#int f0/1.1
Router(config-subif)#encapsulation dot1q 30
Router(config-subif)#ip address 192.168.3.168 255.255.255.0
Router(config)#int f0/1.2
Router(config-subif)#encapsulation dot1q 40
Router(config-subif)#ip address 192.168.4.168 255.255.255.0

交换机配置:
Switch(config)#int 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#vlan 30
Switch(config-vlan)#exit
Switch(config)#vlan 40
Switch(config-vlan)#exit
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 30
Switch(config-vlan)#exit
Switch(config)#int f0/3
Switch(config-if)#switchport access vlan 40

静态路由的配置的拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器Router1配置:
Router>enable 
Router#configure 
Router(config)#interface f0/0
Router(config-if)#ip address 1.1.1.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface s2/0
Router(config-if)#ip address 1.1.2.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface s3/0
Router(config-if)#ip address 1.1.6.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#ip route 1.1.5.0 255.255.255.0 1.1.2.2  //对方PC网段跳到对方Se2/0端口路由器IP
Router(config)#ip route 1.1.4.0 255.255.255.0 1.1.6.2  //对方PC网段跳到对方Se2/0端口路由器IP

路由器Router2配置:
Router>enable 
Router#configure 
Router(config)#interface f0/0
Router(config-if)#ip address 1.1.5.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface s2/0
Router(config-if)#ip address 1.1.2.2 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface s3/0
Router(config-if)#ip address 1.1.3.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#ip route 1.1.1.0 255.255.255.0 1.1.2.1  //对方PC网段跳到对方Se2/0端口路由器IP
Router(config)#ip route 1.1.4.0 255.255.255.0 1.1.3.2  //对方PC网段跳到对方Se3/0端口路由器IP

路由器Router3配置:
Router>enable 
Router#configure 
Router(config)#interface f0/0
Router(config-if)#ip address 1.1.4.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface s3/0
Router(config-if)#ip address 1.1.3.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface s2/0
Router(config-if)#ip address 1.1.6.2 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#ip route 1.1.5.0 255.255.255.0 1.1.3.1  //对方PC网段跳到对方Se3/0端口路由器IP
Router(config)#ip route 1.1.1.0 255.255.255.0 1.1.6.1  //对方PC网段跳到对方Se3/0端口路由器IP

动态RIP路由拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器A的配置
Router>en
Router#config t
Router(config)#int s0/3/0  //WIC-2T模块
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#clock rate 64000 //时钟
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#route rip  //启动rip进程
Router(config-router)#version 2  //启动rip版本2
Router(config-router)#network 192.168.1.0  //发布rip网段
Router(config-router)#no auto-summary  //关闭路由协议的自动汇总
Router(config-router)#exit

路由器B的配置
Router>en 
Router#config t
Router(config)#int s0/3/0
Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int s0/3/1
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#route rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#no auto-summary
Router(config-router)#exit

路由器C的配置
Router>en
Router#config
Router(config)#int s0/3/1
Router(config-if)#ip add 192.168.2.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int s0/3/0
Router(config-if)#ip add 192.168.3.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#route rip
Router(config-router)#version 2
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
Router(config-router)#no auto-summary
Router(config-router)#exit

路由器D的配置
Router>en
Router#config t
Router(config)#int s0/3/0
Router(config-if)#ip add 192.168.3.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#route rip
Router(config-router)#version 2
Router(config-router)#network 192.168.3.0
Router(config-router)#no auto-summary
Router(config-router)#exit

单臂路由与RIP路由拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

交换机A配置:
Switch>enable 
Switch#configure 
Switch(config)#vlan 11
Switch(config-vlan)#ex
Switch(config)#vlan 12
Switch(config-vlan)#ex
Switch(config)#interface f0/11
Switch(config-if)#switchport access vlan 11
Switch(config-if)#ex
Switch(config)#interface f0/12
Switch(config-if)#switchport access vlan 12
Switch(config)#interface f0/1
Switch(config-if)#switchport mode trunk 

交换机B配置:
Switch>enable 
Switch#configure 
Switch(config)#vlan 21
Switch(config-vlan)#ex
Switch(config)#vlan 22
Switch(config-vlan)#ex
Switch(config)#interface f0/21
Switch(config-if)#switchport access vlan 21
Switch(config-if)#ex
Switch(config)#interface f0/22
Switch(config-if)#switchport access vlan 22
Switch(config)#interface f0/1
Switch(config-if)#switchport mode trunk 

路由器A配置:
Router>enable 
Router#configure 
Router(config)#interface fa0/1
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#interface f0/1.1
Router(config-subif)#encapsulation dot1Q 11 //封装Vlan11
Router(config-subif)#ip address 192.168.11.254 255.255.255.0
Router(config-subif)#exit
Router(config)#interface f0/1.2
Router(config-subif)#encapsulation dot1Q 12 //封装Vlan12
Router(config-subif)#ip address 192.168.12.254 255.255.255.0
Router(config)#interface f0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.252
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#router rip  //启动rip进程
Router(config-router)#version 2 //启动rip版本2
Router(config-router)#network 192.168.11.254 //发布rip网段
Router(config-router)#network 192.168.12.254 //发布rip网段
Router(config-router)#network 192.168.10.0 //关闭路由协议的自动汇总
Router(config-router)#exit

路由器B配置:
Router>enable 
Router#configure 
Router(config)#interface fa0/1
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#interface f0/1.1
Router(config-subif)#encapsulation dot1Q 21
Router(config-subif)#ip address 192.168.21.254 255.255.255.0
Router(config-subif)#exit
Router(config)#interface f0/1.2
Router(config-subif)#encapsulation dot1Q 22
Router(config-subif)#ip address 192.168.22.254 255.255.255.0
Router(config)#interface f0/0
Router(config-if)#ip address 192.168.10.2 255.255.255.252
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#router rip 
Router(config-router)#version 2
Router(config-router)#network 192.168.21.254
Router(config-router)#network 192.168.22.254
Router(config-router)#network 192.168.10.0
Router(config-router)#exit

OSPF单区域配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器A配置:
Router>en
Router#config t
Router(config)#int s0/3/0
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int loopback 0 //本地环回
Router(config-if)#ip add 192.168.1.1 255.255.255.0 //环回地址
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#router ospf 10 //ospf是值开放最短路径的优先协议 10是值自治系统号
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0

路由器B配置:
Router>en
Router#config t
Router(config)#int s0/3/0
Router(config-if)#ip add 102.168.2.2 255.255.255.0
Router(config-if)#no shut
Router(config)#int s0/3/1
Router(config-if)#ip add 192.168.3.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#router ospf 10
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0

路由器C配置:
Router>en
Router#config t
Router(config)#int s0/3/1
Router(config-if)#ip add 192.168.3.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int loopback 0
Router(config-if)#ip add 192.168.4.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#router ospf 10
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0
Router(config-router)#network 192.168.4.0 0.0.0.255 area 0

OSPF单区域与PC配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器A配置:
Router>enable 
Router#configure 
Router(config)#int f0/0
Router(config-if)#ip address 192.168.1.3 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#interface s0/3/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#router ospf 10
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0

路由器B配置:
Router>enable 
Router#configure 
Router(config)#int s0/3/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#interface s0/3/1
Router(config-if)#ip address 192.168.3.1
Router(config-if)#no shutdown 
Router(config-if)#clock rate 64000
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#ex
Router(config)#router ospf 10
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0

路由器C配置:
Router>enable 
Router#configure 
Router(config)#interface s0/3/1
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int s0/3/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#exit 
Router(config)#router ospf 10
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0
Router(config-router)#network 192.168.4.0 0.0.0.255 area 0

路由器D配置:
Router>enable 
Router#configure 
Router(config)#int f0/0
Router(config-if)#ip address 192.168.5.3 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#interface s0/3/0
Router(config-if)#ip address 192.168.4.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config)#router ospf 10
Router(config-router)#network 192.168.4.0 0.0.0.255 area 0
Router(config-router)#network 192.168.5.0 0.0.0.255 area 0
show ip ospf neighbor //显示OSPF相关的邻居信息

单臂路由RIP与OSPF单区域配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

交换机A配置:
Switch>enable 
Switch#configure 
Switch(config)#vlan 10
Switch(config-vlan)#ex
Switch(config)#vlan 20
Switch(config-vlan)#ex
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#ex
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#ex
Switch(config)#int f0/24
Switch(config-if)#switchport mode trunk 

交换机B配置:
Switch>enable 
Switch#configure 
Switch(config)#vlan 30
Switch(config-vlan)#ex
Switch(config)#vlan 40
Switch(config-vlan)#ex
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 30
Switch(config-if)#ex
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 40
Switch(config-if)#ex
Switch(config)#int f0/24
Switch(config-if)#switchport mode trunk 

交换机C配置:
Switch>enable 
Switch#configure 
Switch(config)#vlan 50
Switch(config-vlan)#ex
Switch(config)#vlan 60
Switch(config-vlan)#ex
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 50
Switch(config-if)#ex
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 60
Switch(config-if)#ex
Switch(config)#int f0/24
Switch(config-if)#switchport mode trunk 

路由器A配置:
Router>enable 
Router#configure 
Router(config)#interface f0/0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int f0/0.1
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#ex
Router(config)#interface f0/0.2
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#ex
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.1
Router(config-router)#network 192.168.2.1
Router(config-router)#ex
Router(config)#interface s0/3/0
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#clock rate 64000
Router(config-if)#ex
Router(config)#router ospf 10
Router(config-router)#network 192.168.10.0 0.0.0.255 area 0
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0

路由器B配置:
Router>enable 
Router#configure 
Router(config)#interface f0/0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int f0/0.1
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 192.168.3.1 255.255.255.0
Router(config-subif)#ex
Router(config)#interface f0/0.2
Router(config-subif)#encapsulation dot1Q 40
Router(config-subif)#ip address 192.168.4.1 255.255.255.0
Router(config-subif)#ex
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.3.1
Router(config-router)#network 192.168.4.1
Router(config-router)#ex
Router(config)#interface s0/3/0
Router(config-if)#ip address 192.168.10.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#interface s0/3/1
Router(config-if)#ip address 192.168.11.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#router ospf 10
Router(config-router)#network 192.168.10.0 0.0.0.255 area 0
Router(config-router)#network 192.168.11.0 0.0.0.255 area 0
Router(config-router)#network 192.168.3.0 0.0.0.255 area 0
Router(config-router)#network 192.168.4.0 0.0.0.255 area 0

路由器C配置:
Router>enable 
Router#configure 
Router(config)#interface f0/0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int f0/0.1
Router(config-subif)#encapsulation dot1Q 50
Router(config-subif)#ip address 192.168.5.1 255.255.255.0
Router(config-subif)#ex
Router(config)#interface f0/0.2
Router(config-subif)#encapsulation dot1Q 60
Router(config-subif)#ip address 192.168.6.1 255.255.255.0
Router(config-subif)#ex
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.5.1
Router(config-router)#network 192.168.6.1
Router(config-router)#ex
Router(config)#interface s0/3/1
Router(config-if)#ip address 192.168.11.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#router ospf 10
Router(config-router)#network 192.168.11.0 0.0.0.255 area 0
Router(config-router)#network 192.168.5.0 0.0.0.255 area 0
Router(config-router)#network 192.168.6.0 0.0.0.255 area 0

OSPF多区域配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器A配置:
Router>enable 
Router#configure 
Router(config)#int s0/3/0
Router(config-if)#ip address 192.168.12.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#interface loopback 0
Router(config-if)#ip address 1.1.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#router ospf 1
Router(config-router)#router-id 1.1.1.1
Router(config-router)#network 1.1.1.0 255.255.255.0 area 1
Router(config-router)#network 192.168.12.0 255.255.255.0 area 1
Router(config-router)#exit 

路由器B配置:
Router>enable 
Router#configure 
Router(config)#int s0/3/0
Router(config-if)#ip address 192.168.12.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit 
Router(config)#int s0/3/1
Router(config-if)#ip address 192.168.23.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#exit 
Router(config)#int loopback 0
Router(config-if)#ip address 2.2.2.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit 
Router(config)#router ospf 1
Router(config-router)#router-id 2.2.2.2
Router(config-router)#network 192.168.12.0 255.255.255.0 area 1
Router(config-router)#network 192.168.23.0 255.255.255.0 area 0
Router(config-router)#network 2.2.2.0 255.255.255.0 area 0
Router(config-router)#exit 

路由器C配置:
Router>enable 
Router#configure 
Router(config)#int s0/3/1
Router(config-if)#ip address 192.168.23.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int s0/3/0
Router(config-if)#ip address 192.168.34.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int loopback 0
Router(config-if)#ip address 3.3.3.3 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit 
Router(config)#router ospf 1
Router(config-router)#router-id 3.3.3.3
Router(config-router)#network 192.168.23.0 255.255.255.0 area 0
Router(config-router)#network 192.168.34.0 255.255.255.0 area 2
Router(config-router)#network 3.3.3.0 255.255.255.0 area 0
Router(config-router)#exit 

路由器D配置:
Router>enable 
Router#configure 
Router(config)#int s0/3/0
Router(config-if)#ip address 192.168.34.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit 
Router(config)#int loopback 0
Router(config-if)#ip address 4.4.4.4 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit 
Router(config)#router ospf 1
Router(config-router)#router-id 4.4.4.4
Router(config-router)#network 192.168.34.0 0.0.0.255 area 2
Router(config-router)#redistribute connected subnets  //重发布携带子网的直连路由

快速生成树配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器A配置:
Switch>enable 
Switch#configure 
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk 
Switch(config-if)#exit
Switch(config)#int f0/2
Switch(config-if)#switchport mode trunk 
Switch(config-if)#exit
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.0.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface f0/5
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#spanning-tree portfast default //生成树协议
Switch(config)#exit
Switch#show spanning-tree

路由器B配置:
Switch>enable 
Switch#configure 
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk 
Switch(config-if)#exit
Switch(config)#int f0/2
Switch(config-if)#switchport mode trunk 
Switch(config-if)#exit
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.0.2 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface f0/5
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#spanning-tree portfast default //生成树协议
Switch(config)#exit
Switch#show spanning-tree

交换机与三层交换机连到服务器拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

交换机S0:
Switch>en
Switch#conf
Switch(config)#vlan 10
Switch(config-vlan)#ex
Switch(config)#vlan 20
Switch(config-vlan)#ex
Switch(config)#vlan 30
Switch(config-vlan)#ex
Switch(config)#vlan 40
Switch(config-vlan)#ex
Switch(config)#interface f0/1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#ex
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#ex
Switch(config)#interface range f0/5,f0/3,f0/4
Switch(config-if-range)#switchport mode trunk 
Switch(config-if-range)#ex

交换机S1:
Switch>en
Switch#conf
Switch(config)#vlan 10
Switch(config-vlan)#ex
Switch(config)#vlan 20
Switch(config-vlan)#ex
Switch(config)#vlan 30
Switch(config-vlan)#ex
Switch(config)#vlan 40
Switch(config-vlan)#ex
Switch(config)#interface f0/1
Switch(config-if)#switchport access vlan 30
Switch(config-if)#ex
Switch(config)#interface f0/2
Switch(config-if)#switchport access vlan 40
Switch(config-if)#ex
Switch(config)#interface range f0/5,f0/3,f0/4
Switch(config-if-range)#switchport mode trunk 
Switch(config-if-range)#ex

交换机S2:
Switch>en
Switch#conf
Switch(config)#vlan 10
Switch(config-vlan)#ex
Switch(config)#vlan 20
Switch(config-vlan)#ex
Switch(config)#vlan 30
Switch(config-vlan)#ex
Switch(config)#vlan 40
Switch(config-vlan)#ex
Switch(config)#interface range f0/1,f0/3,f0/5
Switch(config-if-range)#switchport mode trunk 
Switch(config-if-range)#ex

交换机S3:
Switch>en
Switch#conf
Switch(config)#vlan 10
Switch(config-vlan)#ex
Switch(config)#vlan 20
Switch(config-vlan)#ex
Switch(config)#vlan 30
Switch(config-vlan)#ex
Switch(config)#vlan 40
Switch(config-vlan)#ex
Switch(config)#interface range f0/1,f0/3,f0/5
Switch(config-if-range)#switchport mode trunk 
Switch(config-if-range)#ex

三层交换机:
Switch>enable 
Switch#configure 
Switch(config)#vlan 10
Switch(config-vlan)#ex
Switch(config)#vlan 20
Switch(config-vlan)#ex
Switch(config)#vlan 30
Switch(config-vlan)#ex
Switch(config)#vlan 40
Switch(config-vlan)#ex
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.1.254 255.255.255.0
Switch(config-if)#ex
Switch(config)#interface vlan 20
Switch(config-if)#ip address 192.168.2.254 255.255.255.0
Switch(config-if)#ex
Switch(config)#interface vlan 30
Switch(config-if)#ip address 192.168.3.254 255.255.255.0
Switch(config-if)#ex
Switch(config)#interface vlan 40
Switch(config-if)#ip address 192.168.4.254 255.255.255.0
Switch(config-if)#ex
Switch(config)#ip routing
Switch(config)#interface g0/1
Switch(config-if)#no switchport 
Switch(config-if)#ip address 192.168.5.1 255.255.255.0
Switch(config-if)#no shutdown 
Switch(config-if)#ex
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.5.2

路由器R0:
Router>enable
Router#configure 
Router(config)#interface g0/1
Router(config-if)#ip address 192.168.5.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.5.1
Router(config)#interface g0/0
Router(config-if)#ip address 192.168.6.254 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex

静态路由NAT拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器R1配置:
Router>enable 
Router#configure 
Router(config)#interface f0/0
Router(config-if)#ip address 172.168.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ip nat inside //内部nat网络
Router(config-if)#ex
Router(config)#interface f0/1
Router(config-if)#ip address 210.16.1.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ip nat outside //外部nat网络
Router(config-if)#ex
Router(config)#ip nat inside source static 172.168.1.10 210.16.1.3 //静态NAT(一对一IP绑定)
Router(config)#ip nat inside source static 172.168.1.20 210.16.1.4 //静态NAT(一对一IP绑定)
Router(config)#ip route 192.168.1.0 255.255.255.0 210.16.1.1
Router(config)#ex
Router#show ip nat translations  //查动态 nat 

路由器R2配置:
Router>enable
Router#configure 
Router(config)#interface f0/1
Router(config-if)#ip address 210.16.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface f0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit

动态路由NAT拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器R1配置:
Router>en
Router#conf
Router(config)#int f0/0
Router(config-if)#ip address 172.168.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ip nat inside //内部网络
Router(config-if)#ex
Router(config)#int f0/1
Router(config-if)#ip address 210.28.1.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ip nat outside //外部网络
Router(config-if)#ex
Router(config)#ip route 192.168.1.0 255.255.255.0 210.28.1.1  //静态路由
Router(config)#ip nat pool xie 210.28.1.10 210.28.1.20 netmask 255.255.255.0  //设置地址池,名称为xie
Router(config)#access-list 1 permit 172.168.1.0 0.0.0.255 //允许172.168.1.0的网段通过
Router(config)#ip nat inside source list 1 pool xie //访问控制列表

路由器R2配置:
Router>enable
Router#configure 
Router(config)#interface f0/1
Router(config-if)#ip address 210.16.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#interface f0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit

PAT配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器R0配置:
Router>en
Router#conf
Router(config)#int f0/0
Router(config-if)#ip address 192.168.10.254 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#interface f0/1
Router(config-if)#ip address 210.10.10.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config)#access-list 1 permit 192.168.10.0 0.0.0.255
Router(config)#ip nat pool xie 210.10.10.1 210.10.10.5 netmask 255.255.255.0
Router(config)#ip nat inside source list 1 pool xie overload 
Router(config)#interface f0/0
Router(config-if)#ip nat inside 
Router(config-if)#ex
Router(config)#int f0/1
Router(config-if)#ip nat outside 
Router(config-if)#ex
Router(config)#ex
Router#show ip nat translations 

标准IP访问控制列表拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器R0配置:
Router>enable 
Router#configure 
Router(config)#int f0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int f0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int s0/3/0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown 
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#ex
Router(config)#ip route 192.168.4.0 255.255.255.0 192.168.3.2
Router(config)#ip access-list standard 10  #10策略编号
Router(config-std-nacl)#permit 192.168.1.0 0.0.0.255  //允许通过
Router(config-std-nacl)#deny 192.168.2.0 0.0.0.255  //禁止通过
Router(config-std-nacl)#exit
Router(config)#int s0/3/0
Router(config-if)#ip access-group 10 out  //出口out
Router(config-if)#exit

路由器R2配置:
Router>en
Router#conf
Router(config)#int f0/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#int s0/3/0
Router(config-if)#no shutdown 
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.1
Router(config)#exit

扩展IP访问控制列表拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器R0配置:
Router>
Router>en
Router#conf
Router(config)#int f0/1
Router(config-if)#ip address 10.26.31.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int f0/0
Router(config-if)#ip address 10.26.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#ip route 0.0.0.0 0.0.0.0 10.26.1.2

路由器R1配置:
Router>en
Router#conf
Router(config)#int f0/0
Router(config-if)#ip address 10.26.2.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#ip route 0.0.0.0 0.0.0.0 10.26.1.1
Router(config)#int f0/0
Router(config-if)#ip address 10.26.1.2 255.255.255.0
Router(config-if)#exit
Router(config)#int s0/3/0
Router(config-if)#ip address 10.26.2.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#clock rate 64000
Router(config-if)#ex
Router(config)#ip route 192.168.26.0 255.255.255.0 10.26.2.2
Router(config)#access-list 100 permit tcp host 10.26.31.10 host 192.168.26.10 eq www //允许tcp协议访问 10.26.31.10 源地址 192.168.26.10 目标地址 www万维网服务
Router(config)#access-list 100 permit tcp host 10.26.31.20 host 192.168.26.10 eq www
Router(config)#access-list 100 deny  icmp  host 10.26.31.10 host 192.168.26.10 echo  //拒绝icmp协议访问到服务器
Router(config)#access-list 100 deny  icmp  host 10.26.31.20 host 192.168.26.10 echo
Router(config)#int s0/3/0
Router(config-if)#ip access-group 100 out //将控制列表编号100应用到s0/3/0端口的出口
Router(config-if)#ex

路由器R2配置:
Router>en
Router#conf
Router(config)#int f0/0
Router(config-if)#ip address 192.168.26.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int s0/3/0
Router(config-if)#ip address 10.26.2.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex

扩展访问练习拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器R0配置:
Router>enable 
Router#conf
Router(config)#int f0/0
Router(config-if)#ip address 10.26.31.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int f0/1
Router(config-if)#ip address 10.26.32.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int f1/0
Router(config-if)#ip address 10.26.33.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int s0/3/0
Router(config-if)#ip address 10.26.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#clock rate 64000
Router(config-if)#ex
Router(config)#ip route 192.168.26.0 255.255.255.0 10.26.1.2

路由器R1配置:
Router>enable 
Router#conf
Router(config)#int s0/3/0
Router(config-if)#ip address 10.26.1.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#ip route 0.0.0.0 0.0.0.0 10.26.1.1
Router(config)#int f0/0
Router(config-if)#ip address 192.168.26.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#access-list 101 permit tcp host 10.26.33.10 host 192.168.26.10 eq 80
Router(config)#access-list 101 deny icmp host 10.26.32.10 host 192.168.26.10 echo
Router(config)#access-list 101 deny ip host 10.26.33.10 host 192.168.26.20
Router(config)#int f0/0
Router(config-if)#ip access-group 101 out

PPP协议配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器R0:
Router>enable 
Router#configure 
Router(config)#username test password test
Router(config)#int s0/0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#encapsulation ppp  //封装PPP协议
Router(config-if)#ppp authentication pap //ppp使用pap的用户名密码验证
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#exit
Router#ping 192.168.1.2

路由器R1:
Router>en
Router#conf
Router(config)#username test2 password test2
Router(config)#int s0/0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#encapsulation ppp 
Router(config-if)#ppp pap sent-username test password test
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#int s0/0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#encapsulation ppp
Router(config-if)#ppp authentication chap 
Router(config-if)#exit

路由器R2:
Router>en
Router#config t
Router(config)#username test3 password test3
Router(config)#int s0/0/1
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#encapsulation ppp
Router(config-if)#ppp authentication chap  //认证客户端
Router(config-if)#no shutdown
Router(config-if)#exit

DHCP配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

交换机S2:
Switch>enable 
Switch#configure 
Switch(config)#interface f0/3
Switch(config-if)#no shutdown 
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#vlan 10
Switch(config-vlan)#ex
Switch(config)#int f0/2
Switch(config-if)#no shutdown 
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit

三层交换S2:
Switch>enable 
Switch#configure 
Switch(config)#vlan 10
Switch(config-vlan)#ex
Switch(config)#vlan 20
Switch(config-vlan)#ex
Switch(config)#int f0/1
Switch(config-if)#exit
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.1.254 255.255.255.0
Switch(config-if)#ex
Switch(config)#int vlan 20
Switch(config-if)#ip address 192.168.2.254 255.255.255.0
Switch(config-if)#ex
Switch(config)#int fa0/2
Switch(config-if)#switchport trunk encapsulation dot1q 
Switch(config-if)#no switchport 
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#ex
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#ex
Switch(config)#int f0/3
Switch(config-if)#no shutdown 
Switch(config-if)#switchport access vlan 20
Switch(config-if)#no shutdown 
Switch(config-if)#ex
Switch(config)#int vlan 10
Switch(config-if)#ip helper-address 192.168.10.1
Switch(config-if)#ex
Switch(config)#int vlan 20
Switch(config-if)#ip helper-address 192.168.10.1
Switch(config-if)#ex
Switch(config)#ip routing
Switch(config)#ip dhcp pool vlan10
Switch(dhcp-config)#network 192.168.1.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.1.254
Switch(dhcp-config)#dns-server 8.8.8.8
Switch(dhcp-config)#ex
Switch(config)#ip dhcp pool vlan20
Switch(dhcp-config)#network 192.168.2.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.2.254
Switch(dhcp-config)#dns-server 8.8.8.8
Switch(dhcp-config)#ex
Switch(config)#ip route 192.168.10.0 255.255.255.0 192.168.20.254

路由器R2:
Router>enable 
Router#configure 
Router(config)#int f0/0
Router(config-if)#no shutdown 
Router(config-if)#ip address 192.168.20.254 255.255.255.0
Router(config-if)#ex
Router(config)#int f0/1
Router(config-if)#ip address 192.168.10.254 255.255.255.0
Router(config-if)#no shutdown 
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.20.1
Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.20.1

EIGRP配置拓扑图:

 路由器与交换机配置学习记录(18-5-24已更新)

路由器R1:
Router>enable 
Router#configure 
Router(config)#int f0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int f0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#router eigrp 100
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#no auto-summary 
Router(config-router)#ex

路由器R2:
Router>enable 
Router#configure 
Router(config)#int f0/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#ex
Router(config)#int f0/1
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config)#router eigrp 100
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
Router(config-router)#no auto-summary 
Router(config-router)#ex

路由器R3:
Router>enable 
Router#configure 
Router(config)#int f0/0
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#int f0/1
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown 
Router(config-if)#exit
Router(config)#router eigrp 100
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.4.0
Router(config-router)#no auto-summary 
Router(config-router)#ex

 

路由器与交换机配置学习记录(18-5-24已更新)

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据

加载中……